Click here to Skip to main content
15,502,045 members
Please Sign up or sign in to vote.
1.67/5 (2 votes)
Hi, we have a solution with some Live unit tests inside and also a separate solution which is linked and contains 'legacy' unit tests. The legacy tests run fine and are output to Azure pipeline test statistics correctly. However the Live ones are not, instead we see the following error:
"No test is available in...make sure that test discoverer & executors are registered and platform & framework version settings are appropriate and try again".

Upon further investigation it seems this is caused by new .dll files being created and 2 missing .dlls. Specifically, the missing ones are:
Microsoft.VisualStudio.TestPlatform.TestFrameword.dll
Microsoft.VisualStudio.TestPlatform.TestFrameword.Extensions.dll

Additionally the newer .dlls that are produced are:
Microsoft.VisualStudio.TestPlatform.MSTest.TestAdapter.dll
Microsoft.VisualStudio.TestPlatform.MSTestAdapter.PlatformServices.dll
Microsoft.VisualStudio.TestPlatform.MSTestAdapter.PlatformServices.Interface.dll

I would prefer the above three to be older versions. I select Visual Studio 2019 from the "Test platform version" drop down list when setting up the unit tests task in Azure. Is there something else I need to pass in or set? Nuget packages or something? I'm very new to Azure and know little, thanks in advance!

What I have tried:

I have reached the point where I understand the cause of the problem but not how to solve it as I'm new to Azure.
Posted
Updated 12-Apr-22 6:20am
Comments
Rajeev Jayaram 12-Apr-22 11:20am    
What do you mean by Live Unit Tests?

1 solution

I believe this issue isn't related to Azure. What do you mean by Live Unit Tests?. You issue is some unit tests are not discoverable, most likely due to missing references in your solution/project file. Also check your pipeline build project too for any missing test/project references. Hope this solves your issue.
 
Share this answer
 
Comments
Danpeking 12-Apr-22 12:18pm    
They're discoverable. If I run the VSTest.Console.exe command against the files deployed on my build server, I receive the error - "No test is available in...make sure that test discoverer & executors are registered and platform & framework version settings are appropriate and try again".

If I then copy the following .dll files to the same folder..
Microsoft.VisualStudio.TestPlatform.TestFrameword.dll
Microsoft.VisualStudio.TestPlatform.TestFrameword.Extensions.dll

As well as update the following .dll files with older versions then the tests run fine and no error.
Microsoft.VisualStudio.TestPlatform.MSTest.TestAdapter.dll
Microsoft.VisualStudio.TestPlatform.MSTestAdapter.PlatformServices.dll
Microsoft.VisualStudio.TestPlatform.MSTestAdapter.PlatformServices.Interface.dll

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900