Click here to Skip to main content
15,877,888 members
Home / Discussions / COM
   

COM

 
AnswerRe: com local server Pin
Stephen Hewitt8-Jun-10 14:29
Stephen Hewitt8-Jun-10 14:29 
GeneralRe: com local server Pin
vasuvasanth8-Jun-10 21:40
vasuvasanth8-Jun-10 21:40 
GeneralRe: com local server Pin
Stephen Hewitt9-Jun-10 15:21
Stephen Hewitt9-Jun-10 15:21 
Questionwant article for com and dcom Pin
Honeyboy_206-Jun-10 16:35
Honeyboy_206-Jun-10 16:35 
QuestionDirectshow Audio Question Pin
godspeed1233-Jun-10 8:07
godspeed1233-Jun-10 8:07 
QuestionMIDL2020 : error generating type library [modified] Pin
forexsurfr29-May-10 19:09
forexsurfr29-May-10 19:09 
AnswerRe: MIDL2020 : error generating type library Pin
forexsurfr30-May-10 7:29
forexsurfr30-May-10 7:29 
QuestionWindows 7 starting new app instance from Visual Studio 2005 Pin
StevenS_Dev21-May-10 9:42
StevenS_Dev21-May-10 9:42 
Something puzzling is happening and I don't understand why. I tested using both my C# and VB.NET test apps and both result in the same behavior. When I run the application I have the following line (C#):
m_COMApp = new SignalServer.Application();


No matter what I do, I always get a new instance of the COM server, even if the server is already up and running. This does not happen in XP and I don't recall it ever happening under Vista (I plan to re-test that this weekend as I have Vista at home). This only happens when I run the COM client directly from within Visual Studio. I even changed my reference to point to another version of the server, and it still wanted to load the server found in the original directory.

I decided to run the application by double-clicking in Explorer and then I get the expected behavior. That is, if a server is already running, it will simply attach to the currently running server. Anyone know why I get the other behavior? Some thoughts are:

1) I am on Visual Studio 2005. Maybe this won't happen in 2010.
2) All the applications are 32-bit apps and the OS is 64-bit. Maybe because of the x86 directory names, things get a little messed up?

Anyone else experience this? Thanks for any information.
QuestionRe: Windows 7 starting new app instance from Visual Studio 2005 Pin
Randor 28-May-10 4:17
professional Randor 28-May-10 4:17 
AnswerRe: Windows 7 starting new app instance from Visual Studio 2005 Pin
StevenS_Dev28-May-10 7:38
StevenS_Dev28-May-10 7:38 
QuestionGetting COM Error: Scalar deleting destructor. Pin
KTTransfer20-May-10 21:10
KTTransfer20-May-10 21:10 
AnswerRe: Getting COM Error: Scalar deleting destructor. Pin
Stephen Hewitt20-May-10 21:54
Stephen Hewitt20-May-10 21:54 
GeneralRe: Getting COM Error: Scalar deleting destructor. Pin
KTTransfer20-May-10 22:34
KTTransfer20-May-10 22:34 
GeneralRe: Getting COM Error: Scalar deleting destructor. Pin
Stephen Hewitt22-May-10 22:09
Stephen Hewitt22-May-10 22:09 
QuestionApplication attempted to perform an operation not allowed by the security policy Pin
NarVish19-May-10 1:38
NarVish19-May-10 1:38 
QuestionTROUBLE Passing BYTE Array from Client to COM OUTPROC Server [modified] Pin
K ARUN KUMAR17-May-10 18:22
K ARUN KUMAR17-May-10 18:22 
AnswerRe: TROUBLE Passing BYTE Array from Client to COM OUTPROC Server Pin
Stephen Hewitt17-May-10 19:59
Stephen Hewitt17-May-10 19:59 
GeneralRe: TROUBLE Passing BYTE Array from Client to COM OUTPROC Server Pin
K ARUN KUMAR17-May-10 21:07
K ARUN KUMAR17-May-10 21:07 
GeneralRe: TROUBLE Passing BYTE Array from Client to COM OUTPROC Server Pin
Stephen Hewitt17-May-10 22:33
Stephen Hewitt17-May-10 22:33 
GeneralRe: TROUBLE Passing BYTE Array from Client to COM OUTPROC Server Pin
K ARUN KUMAR17-May-10 23:30
K ARUN KUMAR17-May-10 23:30 
GeneralRe: TROUBLE Passing BYTE Array from Client to COM OUTPROC Server Pin
Stephen Hewitt18-May-10 0:14
Stephen Hewitt18-May-10 0:14 
GeneralRe: TROUBLE Passing BYTE Array from Client to COM OUTPROC Server Pin
K ARUN KUMAR18-May-10 0:32
K ARUN KUMAR18-May-10 0:32 
GeneralRe: TROUBLE Passing BYTE Array from Client to COM OUTPROC Server Pin
Stephen Hewitt18-May-10 0:37
Stephen Hewitt18-May-10 0:37 
GeneralRe: TROUBLE Passing BYTE Array from Client to COM OUTPROC Server Pin
K ARUN KUMAR18-May-10 0:54
K ARUN KUMAR18-May-10 0:54 
GeneralRe: TROUBLE Passing BYTE Array from Client to COM OUTPROC Server Pin
Stephen Hewitt18-May-10 5:25
Stephen Hewitt18-May-10 5:25 

General General    News News    Suggestion Suggestion    Question Question    Bug Bug    Answer Answer    Joke Joke    Praise Praise    Rant Rant    Admin Admin   

Use Ctrl+Left/Right to switch messages, Ctrl+Up/Down to switch threads, Ctrl+Shift+Left/Right to switch pages.