Click here to Skip to main content
15,433,964 members
Home / Discussions / XML / XSL
   

XML / XSL

 
QuestionMultiple namespaces in xslt Pin
MaryJames7-May-14 22:00
MemberMaryJames7-May-14 22:00 
AnswerRe: Multiple namespaces in xslt Pin
Richard MacCutchan7-May-14 22:24
mveRichard MacCutchan7-May-14 22:24 
GeneralRe: Multiple namespaces in xslt Pin
MaryJames8-May-14 3:16
MemberMaryJames8-May-14 3:16 
GeneralRe: Multiple namespaces in xslt Pin
Richard MacCutchan8-May-14 3:19
mveRichard MacCutchan8-May-14 3:19 
QuestionUse XmlAttributeOverrides, but get an InvalidOperationException nevertheless Pin
Christian Treffler2-Apr-14 8:15
MemberChristian Treffler2-Apr-14 8:15 
AnswerRe: Use XmlAttributeOverrides, but get an InvalidOperationException nevertheless Pin
Bernhard Hiller2-Apr-14 21:24
MemberBernhard Hiller2-Apr-14 21:24 
GeneralRe: Use XmlAttributeOverrides, but get an InvalidOperationException nevertheless Pin
Christian Treffler3-Apr-14 4:03
MemberChristian Treffler3-Apr-14 4:03 
QuestionXpath selecting nodes based on multiple attributes Pin
joost.versteegen4-Dec-13 4:28
Memberjoost.versteegen4-Dec-13 4:28 
Hello, I have a xml file and try to select nodes with a xpath query based on multiple attribute values, but can't get it to work. please tell me the correct xpath.
here's part of the xml:
XML
<AppInt ID="91" Type="Get_Rcp_Rel_Content">
      <Tags>
        <tag ID="300" ROLE="REQTRG" PLCID="PLC008" DB="113" ADDRESS="36" LENGTH="1" DATATYPE="INT" />
        <tag ID="301" ROLE="RSPTRG" PLCID="PLC008" DB="113" ADDRESS="38" LENGTH="1" DATATYPE="INT" />
        <tag ID="302" ROLE="modeID" PLCID="PLC008" DB="113" ADDRESS="40" LENGTH="1" DATATYPE="INT" />
        <tag ID="303" ROLE="jobID" PLCID="PLC008" DB="113" ADDRESS="42" LENGTH="1" DATATYPE="INT" />
        <tag ID="304" ROLE="RcpRelID" PLCID="PLC008" DB="113" ADDRESS="44" LENGTH="1" DATATYPE="INT" />
        <tag ID="305" ROLE="Enable" PLCID="PLC008" DB="113" ADDRESS="46" LENGTH="1" BIT="0" DATATYPE="BOOL" />
        <tag ID="306" ROLE="FillingTime" PLCID="PLC008" DB="113" ADDRESS="48" LENGTH="1" DATATYPE="LONG" />
        <tag ID="307" ROLE="FillingRPM" PLCID="PLC008" DB="113" ADDRESS="52" LENGTH="1" DATATYPE="REAL" />
      </Tags>
      <Setpoints>
        <Setpoint JobID="1002" ModeID ="1" Name="Enable" Value="True"/>
        <Setpoint JobID="1002" ModeID ="1" Name="FillingTime" Value="5500"/>
        <Setpoint JobID="1002" ModeID ="1" Name="FillingRPM" Value="53.2"/>
      </Setpoints>
    </AppInt>

and here's my xpath query:
//AppInt [@ID="91"]/Setpoints [Setpoint/@JobID="1002" and Setpoint/@ModeID="1"]/@Name

AnswerRe: Xpath selecting nodes based on multiple attributes Pin
PIEBALDconsult4-Dec-13 4:46
professionalPIEBALDconsult4-Dec-13 4:46 
GeneralRe: Xpath selecting nodes based on multiple attributes Pin
joost.versteegen4-Dec-13 20:50
Memberjoost.versteegen4-Dec-13 20:50 
AnswerRe: Xpath selecting nodes based on multiple attributes Pin
Richard Deeming4-Dec-13 4:57
mveRichard Deeming4-Dec-13 4:57 
QuestionXPath following-sibling Pin
savbace20-Oct-13 23:20
Membersavbace20-Oct-13 23:20 
QuestionXML validation. Pin
Septimus Hedgehog18-Aug-13 22:02
MemberSeptimus Hedgehog18-Aug-13 22:02 
AnswerRe: XML validation. Pin
joost.versteegen5-Dec-13 22:00
Memberjoost.versteegen5-Dec-13 22:00 
QuestionSlow group - noob Xml question - converting binary structure to Xml and back? Pin
charlieg24-Jul-13 3:10
Membercharlieg24-Jul-13 3:10 
AnswerRe: Slow group - noob Xml question - converting binary structure to Xml and back? Pin
Richard MacCutchan24-Jul-13 5:06
mveRichard MacCutchan24-Jul-13 5:06 
GeneralRe: Slow group - noob Xml question - converting binary structure to Xml and back? Pin
charlieg24-Jul-13 5:09
Membercharlieg24-Jul-13 5:09 
QuestionEmpty node when data specified in xsd Pin
DaveyM6918-Jul-13 23:57
professionalDaveyM6918-Jul-13 23:57 
AnswerRe: Empty node when data specified in xsd Pin
Richard MacCutchan19-Jul-13 0:01
mveRichard MacCutchan19-Jul-13 0:01 
GeneralRe: Empty node when data specified in xsd Pin
DaveyM6919-Jul-13 0:06
professionalDaveyM6919-Jul-13 0:06 
GeneralRe: Empty node when data specified in xsd Pin
Richard MacCutchan19-Jul-13 0:14
mveRichard MacCutchan19-Jul-13 0:14 
GeneralRe: Empty node when data specified in xsd Pin
DaveyM6919-Jul-13 0:27
professionalDaveyM6919-Jul-13 0:27 
GeneralRe: Empty node when data specified in xsd Pin
Nicholas Marty19-Jul-13 0:49
professionalNicholas Marty19-Jul-13 0:49 
GeneralRe: Empty node when data specified in xsd Pin
DaveyM6919-Jul-13 3:53
professionalDaveyM6919-Jul-13 3:53 
GeneralRe: Empty node when data specified in xsd Pin
Richard MacCutchan19-Jul-13 2:21
mveRichard MacCutchan19-Jul-13 2:21 

General General    News News    Suggestion Suggestion    Question Question    Bug Bug    Answer Answer    Joke Joke    Praise Praise    Rant Rant    Admin Admin   

Use Ctrl+Left/Right to switch messages, Ctrl+Up/Down to switch threads, Ctrl+Shift+Left/Right to switch pages.