|Thanks for all your replys,
but I cannot change the method name as
for example, the following method will calculate total price and update it to repository,
but also update the
Customer c, such as
depended on the amount he bought:
public void SetTotalPrice(ShoppingCart s, Customer c, List<Product> lp)
and the caller of the method will use
Customer.Role to do other calculation.
Therefore, I cannot change the method name because its purpose is about total price,
the updated of
Customer c is a side effect
I think, in OO design, the above
SetTotalPrice() method is not appropriate, isn't it?