Click here to Skip to main content
15,905,233 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:

sorry for posting here... since I'm programming in VB it seemed to make the most sense. But basically I guess it's Visual Studio itself giving me problems.

The funny effect is: After debugging my application and making any changes (re-building or not doesn't make a difference) then, trying to debug again, nothing happens... I have to close and restart Visual Studio (2010).

Sometimes - but that seems more or less randomly - I get an error message that "the file is in use by another process". So I figure it must be something in my code that produces that, maybe any remains of a thread (I'm not experienced with them and don't fully understand) still in memory.

Does anyone here have an idea where I could begin tracing that? It's really annoying.

I would also be thankful for information about how I could find out if some code (and possibly which) remains in memory despite of having closed the application i.e. terminated the debugging.

Thank you for any hints,

EDIT: Thank you for the help! It seems to turn out that some twisted code was responsible for the effect. After several massive changes, cleans, etc. it didn't happen anymore for some hours now - having bothered me for days before.

What I have tried:

(not relevant for this question, I suppose)
Updated 9-Feb-19 13:03pm
Maciej Los 9-Feb-19 15:20pm    
Have you tried to run MS Visual Studio with admin priviledges?
Sonhospa 9-Feb-19 16:22pm    
Hello Maciej, thank you for your time. Following your hint I deliberately did that, but it's exactly the same.

Just to find out if it has to do with my (probably twisted) code, I started the project in VS Express 2015 (not as admin), which runs it without any problem several times subsequently.
Maciej Los 9-Feb-19 17:01pm    
I'm not talking about project. I'm talking about running MS Visual Studio with admin privileges. Create an icon on Desktop to MS Visual Studio (devenv.exe). Then - right click on that icon, properties -> choose "Advanced". Check a checkbox "Run as Admin...". That's all. It should avoid strange behaviour of MS Visual Studio.
Sonhospa 9-Feb-19 17:05pm    
Maybe I didn't express that clear enough. Of course I started VS2010 (which I usually use) as admin, like you suggested. And the result was similar. The OTHER experiment with VS2015 Express was to find out if my code is involved in the problem or not. And it's obviously not.
[no name] 9-Feb-19 17:18pm    
Look in Task Manager for your app. A window that is not closed properly will keep the whole app alive.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900