Click here to Skip to main content
15,442,754 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
i tried to setup angular project with angular 8 but unfortunetly I installed v 12 and I figured it at the end of the project so I tried to downgrade so that is what happened after trying

dependencies": {
"@angular/animations": "~12.2.8",
"@angular/common": "~12.2.8",
"@angular/compiler": "~12.2.8",
"@angular/core": "~12.2.8",
"@angular/forms": "~12.2.8",
"@angular/platform-browser": "~12.2.8",
"@angular/platform-browser-dynamic": "~12.2.8",
"@angular/router": "~12.2.8",
"@okta/okta-angular": "^3.2.2",
"@okta/okta-signin-widget": "^5.10.1",
"core-js": "^2.5.4",
"rxjs": "~7.3.1",
"tslib": "^1.9.0",
"zone.js": "~0.11.4}

but at the console:

Angular CLI: 8.3.29 Node: 16.4.1 OS: win32 x64 Angular: undefined ...

Package Version

------------------------------------------------------
@angular-devkit/architect    0.803.29 (cli-only)
@angular-devkit/core         8.3.29 (cli-only)
@angular-devkit/schematics   8.3.29 (cli-only)
@schematics/angular          8.3.29 (cli-only)
@schematics/update           0.803.29 (cli-only)

so what should I do?? and if I want to make anew project to avoid this error ..can I copy the Component and Service folder directly to the new one because I cannot start the project from the beginning??

What I have tried:

stackoverflow similar answers to my questions
Posted
Updated 4-Oct-21 20:15pm

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900