Click here to Skip to main content
15,795,402 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more:
After the last upgrade in VS-Code, my background became somewhat transparent from pure dark for some unknown reason.

What I have tried:

I have tried:

  1. Extensions: As some extensions, particularly those related to themes or UI modifications, could potentially interfere with my color settings. So, I have made sure that none of my installed extensions are causing this behavior. I have disabled extensions one by one to identify the culprit, but was unsuccessful to do so.
  2. Theme Settings: Sometimes, as there are some theme settings that might be defined in multiple places, such as the global settings and workspace settings. I have ensured that there are no conflicting theme settings at the workspace level.
  3. Operating System Theme: Some operating systems have built-in transparency settings that could affect the appearance of applications, including Visual Studio Code. I have checked my operating system's settings to ensure that transparency effects are turned off.
  4. Editing the "workbench.colorCustomizations" section in my “settings.json” file: I have also edited “settings.json” file, as below:
    "workbench.colorCustomizations": {
            "[Default High Contrast]": {
                "editor.foreground": "#000",
                "activityBar.background": "#111",
                "sideBar.background": "#000",
                "tab.activeBackground": "#000",
                "editor.background": "#000",
                "editorGutter.background": "#111",
                "statusBar.background": "#111"

Unfortunately, nothing has worked. Do you know how to fix this?
Updated 17-Aug-23 8:38am

Check your Theme: File > Preferences > Theme > Color Theme

The other is File > Preferences > settings > Workbench > Appearance, then Color Theme, Preferred Dark Color Theme, and Preferred High Contrast Color Theme.

I have mine set to "Dark Modern", "Dark Modern", and "Dark High Contrast".
Share this answer
Patrick Tang 2023 18-Aug-23 14:47pm    
Thanks for your suggestion. I have tried this method, but it didn't work.
I have fixed by installing GlassIt-VSC, then press Ctr+Alt+X to minimize transparency.
I have fixed by installing GlassIt-VSC, then press Ctr+Alt+X to minimize transparency.
Share this answer

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900