Click here to Skip to main content
15,798,826 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
I have a property sheet that loads 4 pages. On one of my dialog resources I have a CLinkCtrl object. When that control is on the page, that page will not display within the property sheet. When I remove it, the page loads just fine. What is frustrating is, this used to work just fine.

What I have tried:

Tried changing to CMFCLinkCtrl, recompiling and still no good.
Richard MacCutchan 22-Sep-23 12:39pm    
Please use the Improve question link above, and add complete details of the actual code.

1 solution

I was very curious about this so I made a test dialog with a SysLink control in it and, sure enough, it would not load. So I read the documentation and added a call to InitCommonControlsEx with the ICC_LINK_CLASS flag set and that failed. After a little more reading I think I found the key to the whole thing. A note in one of the docs says, "Version 6 of ComCtl32.dll supports Unicode only." I then made a very simple MFC dialog-based app that IS Unicode and it worked.

So, there you have it - your app HAS to be Unicode to use the control. If yours actually IS Unicode then something else is going on.
Share this answer
Garry I 2021 23-Sep-23 14:07pm    
Good grief, that was EXACTLY the issue. When trying to integrate a new API version, I had switched to the multi-byte character set to accommodate differences in the new API release... I switched back to Unicode and everything worked just fine again. Thanks very much Rick
Rick York 23-Sep-23 14:46pm    
You are welcome.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900